Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 30, 2024 - 09:00 CET
Scheduled
Dear Customer,
we are going to update the a9s platform during the scheduled timeframe.
New Services
a9s Messaging 4.0 has been introduced as a release candidate
Unsupported
a9s Elasticsearch 2
We removed the offering of a9s Elasticsearch 2 from the a9s Data Services, as this version is now unsupported on account of it reaching its EOL on February 2018. We removed the files, version specific examples, references and documentation pages related to the unsupported version. It is particularly important to emphasize that we have removed the offering from the a9s Service Broker catalog of a9s Elasticsearch. This means that it is imperative that you ensure there are no Service Instances of this particular a9s Elasticsearch version running anymore, before upgrading to this version. If this is not the case, please contact our Sales department (sales@anynines.com) before you start the upgrade.
a9s Messaging 3.6
We removed the offering of a9s Messaging 3.6 from the a9s Data Services, as this version is now unsupported on account of it reaching its EOL on May 2018. We removed the files, version specific examples, references and documentation pages related to the unsupported version. It is particularly important to emphasize that we have removed the offering from the a9s Service Broker catalog of a9s Messaging. This means that it is imperative that you ensure there are no Service Instances of this particular a9s Messaging version running anymore, before upgrading to this version. If this is not the case, please contact our Sales department (sales@anynines.com) before you start the upgrade.
a9s MySQL 10.1
We removed the offering of a9s MySQL 10.1 from the a9s Data Services, as this version is now unsupported on account of it reaching its EOL on October 2020. We removed the files, version specific examples, references and documentation pages related to the unsupported version. It is particularly important to emphasize that we have removed the offering from the a9s Service Broker catalog of a9s MySQL. This means that it is imperative that you ensure there are no Service Instances of this particular a9s MySQL version running anymore, before upgrading to this version. If this is not the case, please contact our Sales department (sales@anynines.com) before you start the upgrade.
a9s Redis 3.2
We removed the offering of a9s Redis 3.2 from the a9s Data Services, as this version is now unsupported on account of it reaching its EOL on January 2017. We removed the files, version specific examples, references and documentation pages related to the unsupported version. It is particularly important to emphasize that we have removed the offering from the a9s Service Broker catalog of a9s Redis. This means that it is imperative that you ensure there are no Service Instances of this particular a9s Redis version running anymore, before upgrading to this version. If this is not the case, please contact our Sales department (sales@anynines.com) before you start the upgrade.
a9s Redis 4.0
We removed the offering of a9s Redis 4.0 from the a9s Data Services, as this version is now unsupported on account of it reaching its EOL on January 2019. We removed the files, version specific examples, references and documentation pages related to the unsupported version. It is particularly important to emphasize that we have removed the offering from the a9s Service Broker catalog of a9s Redis. This means that it is imperative that you ensure there are no Service Instances of this particular a9s Redis version running anymore, before upgrading to this version. If this is not the case, please contact our Sales department (sales@anynines.com) before you start the upgrade.
The update procedure is structured into 3 stages:
Stage 1: Update of the Runtime Stage 2: Update of the a9s Data Service Framework Stage 3: Update of all existing a9s Data Service instances
The stages have the following impact:
Stage 1: - Restart of all applications. For slow starting applications with a single instance configuration this might introduce a downtime of up to 5 minutes in addition to application startup time. - Restart of the API. Single requests to the API might fail but subsequent requests shall pass.
Stage 2: - Creation, update and deletion of new or existing a9s Data Services instances will be unavailable for up to 5 minutes. - The availability of existing a9s Data Service instances will not be affected by this.
Stage 3: - All a9s Data Service instances will be restarted which causes single instances to be not available for up to 5 minutes. - You may see your app reconnecting to the master node while the service instance gets updated.
We'll provide an update as soon as we finish the respective stage.
Best regards, The anynines Team
Posted Dec 23, 2024 - 10:24 CET
This scheduled maintenance affected: API, Customer Panel, Services, and Customer applications.