Mitigation of Vulnerability
Scheduled Maintenance Report for anynines
Completed
The scheduled maintenance has been completed.
Posted about 19 hours ago. Aug 20, 2019 - 15:36 CEST
Update
Hi everyone,

the service deployment updates finished which concludes the update.

Note: In the meanwhile we noticed issues with apps using Spring Boot version 1.5.x since the update. The buildpack was not updated so this is likely caused by an incompatibility of the updated cflinuxfs3 stack with older Spring Boot versions. If you're getting the following error, please update your app to Spring Boot v2.x:

java.lang.IllegalStateException: Error processing condition on org.springframework.boot.actuate.autoconfigure.AuditAutoConfiguration$AuditEventRepositoryConfiguration
[...]
Caused by: java.lang.reflect.MalformedParameterizedTypeException: null
[...]

Best regards,

Michael Both
Posted about 19 hours ago. Aug 20, 2019 - 15:35 CEST
Update
Hi everyone,

we will continue with applying some fixed to the service instances in a couple of minutes.

Greetings,

Benjamin
Posted 5 days ago. Aug 16, 2019 - 08:09 CEST
Update
Hi,

the update of the container runtime finished a little while ago and we're be currently updating the backup components.

Kind regards,

Michael Both
Posted 7 days ago. Aug 14, 2019 - 17:10 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 7 days ago. Aug 14, 2019 - 13:46 CEST
Scheduled
Hello,

due to a critical vulnerability (https://www.cloudfoundry.org/blog/cve-2019-9893/) we will upgrade the container runtime of Cloud Foundry today. We will also use this opportunity to fix a rare issue with service backups.

We do not expect downtime during the upgrade for apps, but as the service instances are restarted, single service instances will be unavailable for likely less than 1 min.

Kind regards,

Michael Both
Posted 7 days ago. Aug 14, 2019 - 13:34 CEST
This scheduled maintenance affected: API, Services, and Customer applications.